Symptom: 
Millennium logon fails with the following error:  SQL Server Does Not Exist or Access is denied.  Connection open ( )
As well testing ODBC Web SQL connection on the IIS may fail as well with the following error:
Cause: 
The TCP/IP connections may be failing on the IIS machine.  
Resolution: 
  1. Verify services on Millennium Database Server
    • SQL Server (Millennium SQL Instance) – started, automatic
    • SQL Server Browser – started, automatic
  2. Verify services on Millennium IIS Server
    • Sage Millennium Assignment Service – started, automatic
    • World Wide Web Publishing Service – started, automatic
  3. Verify Web SQL odbc connection (KB 71175 ODBC SQL Setup)
    • Start | Run | %windir%\SysWOW64\odbcad32.exe
    • Confirm appropriate server\instance
    • Validate connection
  4. Verify IIS system can ping database system & vice versa
  5. Reset Millennium Admin password to 'falcon' (delete registry key if necessary\present)
    • Grant sysadmin SQL server role
    • Delete extraneous registry key (KB 252845)
  6. Reconcile values in dbo.report_servers (server_desc, report_server, report_path, report_database, report_millreports) against data in Millennium Web Client
    • Tools | System Upkeep | System Info | Reporting Queues

       
    • Confirm these values are correct\reference the appropriate server\instance.   Adjust via the Millennium Web Interface (see graphic below) or directly edit values in dbo.report_servers


       
Millennium Reporting Queues (SQL Server)
  • Queue:  Your name for the specified queue. If there are multiple queues, this name needs to be unique.
  • Queue Location: Enter the UNC Path to Queue.exe.  (\\<Reporting Server machine name>\Queue).
  • Database Computer:  This is the name of the server (as identified in your network) where the milldata database or a replicated copy of the database is located.  If you have multiple database instances on the same server, you will specify the <server name>\<instance name>.
  • Data Database:  Name of your database, (case sensitive) i.e milldata.
  • Primary Database Computer: Actual system name of the Database Server where production database resides. .  If you have multiple database instances on the same server, you will specify the <server name>\<instance name>.
Additional Information: 
The best way to troubleshoot is to ping the database server from the IIS and the reporting server.

Test the ODBC WebSQL connection from the IIS.  If it is a problem with the IIS, this should fail.  But also test the ODBC WebSQL connection from the reporting server. If this works, then it indicates a problem with the IIS.  Logoff the IIS server and reboot the server if TCP\IP protocol is enabled on the server.

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Article Type: 
Product Issue
Product Line: 
Abila Millennium
Product Module/Feature: 
Data Issues
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